package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(([A-Z]+[ -.]+)|([0-9]+[ -.]+))+`)
var str = `ABCD-012345-EFG-10vXRI47HU-1
ABCD-012345-EFG-10zSD0U/2
ABCD-012345-EFG-10ZsE8h -1
ABCD-012345-EFG- 10zSe9K
ABCD-012345-EFG-.10zSe9K
ABCD-012345-EFG-10zSe9K_2
ABCD-012345-EFG-10zSe9K.
ABCD-012345--EFG-10zSe9K
ABCD-012345-EFG-10zSe9K-
ABCD-012345-EFG-10zSe9K-//1/23h
ABCD-EFGH-HIJK-012345-10zSe9K
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}