import Foundation
let pattern = #"^(([A-Z]+[ -.]+)|([0-9]+[ -.]+))+"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
ABCD-012345-EFG-10vXRI47HU-1
ABCD-012345-EFG-10zSD0U/2
ABCD-012345-EFG-10ZsE8h -1
ABCD-012345-EFG- 10zSe9K
ABCD-012345-EFG-.10zSe9K
ABCD-012345-EFG-10zSe9K_2
ABCD-012345-EFG-10zSe9K.
ABCD-012345--EFG-10zSe9K
ABCD-012345-EFG-10zSe9K-
ABCD-012345-EFG-10zSe9K-//1/23h
ABCD-EFGH-HIJK-012345-10zSe9K
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)