const regex = /^(([A-Z]+[ -.]+)|([0-9]+[ -.]+))+/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([A-Z]+[ -.]+)|([0-9]+[ -.]+))+', 'gmi')
const str = `ABCD-012345-EFG-10vXRI47HU-1
ABCD-012345-EFG-10zSD0U/2
ABCD-012345-EFG-10ZsE8h -1
ABCD-012345-EFG- 10zSe9K
ABCD-012345-EFG-.10zSe9K
ABCD-012345-EFG-10zSe9K_2
ABCD-012345-EFG-10zSe9K.
ABCD-012345--EFG-10zSe9K
ABCD-012345-EFG-10zSe9K-
ABCD-012345-EFG-10zSe9K-//1/23h
ABCD-EFGH-HIJK-012345-10zSe9K
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}