// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(([A-Z]+[ -.]+)|([0-9]+[ -.]+))+").unwrap();
let string = "ABCD-012345-EFG-10vXRI47HU-1
ABCD-012345-EFG-10zSD0U/2
ABCD-012345-EFG-10ZsE8h -1
ABCD-012345-EFG- 10zSe9K
ABCD-012345-EFG-.10zSe9K
ABCD-012345-EFG-10zSe9K_2
ABCD-012345-EFG-10zSe9K.
ABCD-012345--EFG-10zSe9K
ABCD-012345-EFG-10zSe9K-
ABCD-012345-EFG-10zSe9K-//1/23h
ABCD-EFGH-HIJK-012345-10zSe9K
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}