import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([A-Z]+[ -.]+)|([0-9]+[ -.]+))+";
final String string = "ABCD-012345-EFG-10vXRI47HU-1\n"
+ "ABCD-012345-EFG-10zSD0U/2\n"
+ "ABCD-012345-EFG-10ZsE8h -1\n"
+ "ABCD-012345-EFG- 10zSe9K \n"
+ "ABCD-012345-EFG-.10zSe9K\n"
+ "ABCD-012345-EFG-10zSe9K_2\n"
+ "ABCD-012345-EFG-10zSe9K.\n"
+ "ABCD-012345--EFG-10zSe9K\n"
+ "ABCD-012345-EFG-10zSe9K-\n"
+ "ABCD-012345-EFG-10zSe9K-//1/23h\n"
+ "ABCD-EFGH-HIJK-012345-10zSe9K\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}