package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^74891.+$`)
var str = `Test 123
1233. 2334
74891.32432 423423 4234234234 234234
abc 123456767.343. 434
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}