import re
regex = re.compile(r"^74891.+$", flags=re.MULTILINE)
test_str = ("Test 123\n"
"1233. 2334\n"
"74891.32432 423423 4234234234 234234\n"
"abc 123456767.343. 434\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")