$re = '/^74891.+$/m';
$str = 'Test 123
1233. 2334
74891.32432 423423 4234234234 234234
abc 123456767.343. 434
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);