// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^74891.+$").unwrap();
let string = "Test 123
1233. 2334
74891.32432 423423 4234234234 234234
abc 123456767.343. 434
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}