re = /^74891.+$/m
str = 'Test 123
1233. 2334
74891.32432 423423 4234234234 234234
abc 123456767.343. 434
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end