# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^((\+?\d{1,4})?[-.\s]?\(?(\d{1,3})?\)?[-.\s]?(\d{1,4})[-.\s]?(\d{1,4})[-.\s]?(\d{1,9}))/$2$3$4$5$6/gm;t' <<< "+49 172 7470791
+49 621 60-6641516
+49 621 60-41516
8-1-6641516
+7(927)296-96-08
61 41516
6641516
41516
"