use strict;
my $str = '+49 172 7470791
+49 621 60-6641516
+49 621 60-41516
8-1-6641516
+7(927)296-96-08
61 41516
6641516
41516
';
my $regex = qr/^((\+?\d{1,4})?[-.\s]?\(?(\d{1,3})?\)?[-.\s]?(\d{1,4})[-.\s]?(\d{1,4})[-.\s]?(\d{1,9}))/mp;
my $subst = '$2$3$4$5$6';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";