using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((\+?\d{1,4})?[-.\s]?\(?(\d{1,3})?\)?[-.\s]?(\d{1,4})[-.\s]?(\d{1,4})[-.\s]?(\d{1,9}))";
string substitution = @"$2$3$4$5$6";
string input = @"+49 172 7470791
+49 621 60-6641516
+49 621 60-41516
8-1-6641516
+7(927)296-96-08
61 41516
6641516
41516
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}