import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((\\+?\\d{1,4})?[-.\\s]?\\(?(\\d{1,3})?\\)?[-.\\s]?(\\d{1,4})[-.\\s]?(\\d{1,4})[-.\\s]?(\\d{1,9}))";
final String string = "+49 172 7470791 \n"
+ "+49 621 60-6641516 \n"
+ "+49 621 60-41516 \n"
+ "8-1-6641516 \n"
+ "+7(927)296-96-08\n"
+ "61 41516 \n"
+ "6641516 \n"
+ "41516 \n";
final String subst = "$2$3$4$5$6";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}