# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((\+?\d{1,4})?[-.\s]?\(?(\d{1,3})?\)?[-.\s]?(\d{1,4})[-.\s]?(\d{1,4})[-.\s]?(\d{1,9}))"
test_str = ("+49 172 7470791 \n"
"+49 621 60-6641516 \n"
"+49 621 60-41516 \n"
"8-1-6641516 \n"
"+7(927)296-96-08\n"
"61 41516 \n"
"6641516 \n"
"41516 \n")
subst = "$2$3$4$5$6"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.