// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((\+?\d{1,4})?[-.\s]?\(?(\d{1,3})?\)?[-.\s]?(\d{1,4})[-.\s]?(\d{1,4})[-.\s]?(\d{1,9}))").unwrap();
let string = "+49 172 7470791
+49 621 60-6641516
+49 621 60-41516
8-1-6641516
+7(927)296-96-08
61 41516
6641516
41516
";
let substitution = "$2$3$4$5$6";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}