using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\w)(?:\Q+end\E|\Qsomething-\E)(?!\w)";
string substitution = @"";
string input = @"oh end m+end something-strange oh something +end something- here";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}