const regex = /(?<!\w)(?:\Q+end\E|\Qsomething-\E)(?!\w)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\w)(?:\\Q+end\\E|\\Qsomething-\\E)(?!\\w)', 'g')
const str = `oh end m+end something-strange oh something +end something- here`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);