$re = '/(?<!\w)(?:\Q+end\E|\Qsomething-\E)(?!\w)/';
$str = 'oh end m+end something-strange oh something +end something- here';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;