using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"shop\.xerox\.com\/(?=.*?\d)(?=.*?[a-zA-Z])[a-zA-Z\d]+\-?.+";
string input = @"https://www.shop.xerox.com/
https://www.shop.xerox.com/products/
https://www.shop.xerox.com/products/printers
https://www.shop.xerox.com/006r04422
https://www.shop.xerox.com/
https://www.shop.xerox.com/xerox-c230";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}