import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "shop\\.xerox\\.com\\/(?=.*?\\d)(?=.*?[a-zA-Z])[a-zA-Z\\d]+\\-?.+";
final String string = "https://www.shop.xerox.com/\n"
+ "https://www.shop.xerox.com/products/\n"
+ "https://www.shop.xerox.com/products/printers\n"
+ "https://www.shop.xerox.com/006r04422\n"
+ "https://www.shop.xerox.com/\n"
+ "https://www.shop.xerox.com/xerox-c230";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}