$re = '/shop\.xerox\.com\/(?=.*?\d)(?=.*?[a-zA-Z])[a-zA-Z\d]+\-?.+/m';
$str = 'https://www.shop.xerox.com/
https://www.shop.xerox.com/products/
https://www.shop.xerox.com/products/printers
https://www.shop.xerox.com/006r04422
https://www.shop.xerox.com/
https://www.shop.xerox.com/xerox-c230';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);