import re
regex = re.compile(r"shop\.xerox\.com\/(?=.*?\d)(?=.*?[a-zA-Z])[a-zA-Z\d]+\-?.+", flags=re.MULTILINE)
test_str = ("https://www.shop.xerox.com/\n"
"https://www.shop.xerox.com/products/\n"
"https://www.shop.xerox.com/products/printers\n"
"https://www.shop.xerox.com/006r04422\n"
"https://www.shop.xerox.com/\n"
"https://www.shop.xerox.com/xerox-c230")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")