#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/user\.slice\/user-\d+\.slice\/user@\d+\.service\/app\.slice\/app(?:-(?:gnome|DDE|flatpak))?-APPID(?:-.+\.scope|(?:@.+)?\.service)"
Local $sString = "/user.slice/user-1000.slice/user@1000.service/app.slice/app-gnome-APPID-969735.scope" & @CRLF & _
"/user.slice/user-1000.slice/user@1000.service/app.slice/app-flatpak-APPID-969735.scope" & @CRLF & _
"/user.slice/user-1000.slice/user@1000.service/app.slice/app-APPID@969735.service" & @CRLF & _
"/user.slice/user-1000.slice/user@1000.service/app.slice/app-APPID.service" & @CRLF & _
"/user.slice/user-1000.slice/user@1000.service/app.slice/app-DDE-APPID.service"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")