using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/user\.slice\/user-\d+\.slice\/user@\d+\.service\/app\.slice\/app(?:-(?:gnome|DDE|flatpak))?-APPID(?:-.+\.scope|(?:@.+)?\.service)";
string input = @"/user.slice/user-1000.slice/user@1000.service/app.slice/app-gnome-APPID-969735.scope
/user.slice/user-1000.slice/user@1000.service/app.slice/app-flatpak-APPID-969735.scope
/user.slice/user-1000.slice/user@1000.service/app.slice/app-APPID@969735.service
/user.slice/user-1000.slice/user@1000.service/app.slice/app-APPID.service
/user.slice/user-1000.slice/user@1000.service/app.slice/app-DDE-APPID.service";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}