$re = '/\/user\.slice\/user-\d+\.slice\/user@\d+\.service\/app\.slice\/app(?:-(?:gnome|DDE|flatpak))?-APPID(?:-.+\.scope|(?:@.+)?\.service)/m';
$str = '/user.slice/user-1000.slice/user@1000.service/app.slice/app-gnome-APPID-969735.scope
/user.slice/user-1000.slice/user@1000.service/app.slice/app-flatpak-APPID-969735.scope
/user.slice/user-1000.slice/user@1000.service/app.slice/app-APPID@969735.service
/user.slice/user-1000.slice/user@1000.service/app.slice/app-APPID.service
/user.slice/user-1000.slice/user@1000.service/app.slice/app-DDE-APPID.service';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);