import Foundation
let pattern = #"\/user\.slice\/user-\d+\.slice\/user@\d+\.service\/app\.slice\/app(?:-(?:gnome|DDE|flatpak))?-APPID(?:-.+\.scope|(?:@.+)?\.service)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/user.slice/user-1000.slice/user@1000.service/app.slice/app-gnome-APPID-969735.scope
/user.slice/user-1000.slice/user@1000.service/app.slice/app-flatpak-APPID-969735.scope
/user.slice/user-1000.slice/user@1000.service/app.slice/app-APPID@969735.service
/user.slice/user-1000.slice/user@1000.service/app.slice/app-APPID.service
/user.slice/user-1000.slice/user@1000.service/app.slice/app-DDE-APPID.service
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)