import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/user\\.slice\\/user-\\d+\\.slice\\/user@\\d+\\.service\\/app\\.slice\\/app(?:-(?:gnome|DDE|flatpak))?-APPID(?:-.+\\.scope|(?:@.+)?\\.service)";
final String string = "/user.slice/user-1000.slice/user@1000.service/app.slice/app-gnome-APPID-969735.scope\n"
+ "/user.slice/user-1000.slice/user@1000.service/app.slice/app-flatpak-APPID-969735.scope\n"
+ "/user.slice/user-1000.slice/user@1000.service/app.slice/app-APPID@969735.service\n"
+ "/user.slice/user-1000.slice/user@1000.service/app.slice/app-APPID.service\n"
+ "/user.slice/user-1000.slice/user@1000.service/app.slice/app-DDE-APPID.service";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}