// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/user\.slice\/user-\d+\.slice\/user@\d+\.service\/app\.slice\/app(?:-(?:gnome|DDE|flatpak))?-APPID(?:-.+\.scope|(?:@.+)?\.service)").unwrap();
let string = "/user.slice/user-1000.slice/user@1000.service/app.slice/app-gnome-APPID-969735.scope
/user.slice/user-1000.slice/user@1000.service/app.slice/app-flatpak-APPID-969735.scope
/user.slice/user-1000.slice/user@1000.service/app.slice/app-APPID@969735.service
/user.slice/user-1000.slice/user@1000.service/app.slice/app-APPID.service
/user.slice/user-1000.slice/user@1000.service/app.slice/app-DDE-APPID.service";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}