const regex = /\/user\.slice\/user-\d+\.slice\/user@\d+\.service\/app\.slice\/app(?:-(?:gnome|DDE|flatpak))?-APPID(?:-.+\.scope|(?:@.+)?\.service)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/user\\.slice\\\/user-\\d+\\.slice\\\/user@\\d+\\.service\\\/app\\.slice\\\/app(?:-(?:gnome|DDE|flatpak))?-APPID(?:-.+\\.scope|(?:@.+)?\\.service)', 'gm')
const str = `/user.slice/user-1000.slice/user@1000.service/app.slice/app-gnome-APPID-969735.scope
/user.slice/user-1000.slice/user@1000.service/app.slice/app-flatpak-APPID-969735.scope
/user.slice/user-1000.slice/user@1000.service/app.slice/app-APPID@969735.service
/user.slice/user-1000.slice/user@1000.service/app.slice/app-APPID.service
/user.slice/user-1000.slice/user@1000.service/app.slice/app-DDE-APPID.service`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}