#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=,")[^"\n]*(?=",)|(?<=,)(?!")[^,\n]*(?<!")(?=,)"
Local $sString = ""0x00000000","What do you want to eat? fish, meat or\n eggs?",""" & @CRLF & _
""0x00030002","What do you want to eat?",""" & @CRLF & _
"0x00030002,What do you want to eat?," & @CRLF & _
""0x00030002","What do you, want to eat?",""" & @CRLF & _
"0x00030002,What do "you want" to eat?," & @CRLF & _
""0x00030002,What do you want to eat?,",?," & @CRLF & _
"" & @CRLF & _
""0x00030002","What do you want to eat?,"" & @CRLF & _
"0x00030002 ,What do you want to eat?"," & @CRLF & _
"" & @CRLF & _
"Note \n is included in [^"\n] merely to test the regex against multiple strings."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")