import Foundation
let pattern = #"(?<=,")[^"\n]*(?=",)|(?<=,)(?!")[^,\n]*(?<!")(?=,)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"0x00000000","What do you want to eat? fish, meat or\n eggs?",""
"0x00030002","What do you want to eat?",""
0x00030002,What do you want to eat?,
"0x00030002","What do you, want to eat?",""
0x00030002,What do "you want" to eat?,
"0x00030002,What do you want to eat?,",?,
"0x00030002","What do you want to eat?,"
0x00030002 ,What do you want to eat?",
Note \n is included in [^"\n] merely to test the regex against multiple strings.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)