const regex = /(?<=,")[^"\n]*(?=",)|(?<=,)(?!")[^,\n]*(?<!")(?=,)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=,")[^"\\n]*(?=",)|(?<=,)(?!")[^,\\n]*(?<!")(?=,)', 'gm')
const str = `"0x00000000","What do you want to eat? fish, meat or\\n eggs?",""
"0x00030002","What do you want to eat?",""
0x00030002,What do you want to eat?,
"0x00030002","What do you, want to eat?",""
0x00030002,What do "you want" to eat?,
"0x00030002,What do you want to eat?,",?,
"0x00030002","What do you want to eat?,"
0x00030002 ,What do you want to eat?",
Note \\n is included in [^"\\n] merely to test the regex against multiple strings.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}