import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=,\")[^\"\\n]*(?=\",)|(?<=,)(?!\")[^,\\n]*(?<!\")(?=,)";
final String string = "\"0x00000000\",\"What do you want to eat? fish, meat or\\n eggs?\",\"\"\n"
+ "\"0x00030002\",\"What do you want to eat?\",\"\"\n"
+ "0x00030002,What do you want to eat?,\n"
+ "\"0x00030002\",\"What do you, want to eat?\",\"\"\n"
+ "0x00030002,What do \"you want\" to eat?,\n"
+ "\"0x00030002,What do you want to eat?,\",?,\n\n"
+ "\"0x00030002\",\"What do you want to eat?,\"\n"
+ "0x00030002 ,What do you want to eat?\",\n\n"
+ "Note \\n is included in [^\"\\n] merely to test the regex against multiple strings.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}