$re = '/(?<=,")[^"\n]*(?=",)|(?<=,)(?!")[^,\n]*(?<!")(?=,)/m';
$str = '"0x00000000","What do you want to eat? fish, meat or\\n eggs?",""
"0x00030002","What do you want to eat?",""
0x00030002,What do you want to eat?,
"0x00030002","What do you, want to eat?",""
0x00030002,What do "you want" to eat?,
"0x00030002,What do you want to eat?,",?,
"0x00030002","What do you want to eat?,"
0x00030002 ,What do you want to eat?",
Note \\n is included in [^"\\n] merely to test the regex against multiple strings.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);