using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=,"")[^""\n]*(?="",)|(?<=,)(?!"")[^,\n]*(?<!"")(?=,)";
string input = @"""0x00000000"",""What do you want to eat? fish, meat or\n eggs?"",""
""0x00030002"",""What do you want to eat?"",""
0x00030002,What do you want to eat?,
""0x00030002"",""What do you, want to eat?"",""
0x00030002,What do ""you want"" to eat?,
""0x00030002,What do you want to eat?,"",?,
""0x00030002"",""What do you want to eat?,""
0x00030002 ,What do you want to eat?"",
Note \n is included in [^""\n] merely to test the regex against multiple strings.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}