#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{5}\s\d{5}\s\d{5}\s\d{1,5}"
Local $sString = "Дано:" & @CRLF & _
" 12334 12323 12334 12323 12334 12312313231231" & @CRLF & _
"12334 12323 12334 12323 12334 12312313231231" & @CRLF & _
"123 123" & @CRLF & _
"12334 12323 12334 " & @CRLF & _
"12334 12323 12334 " & @CRLF & _
"12334 12323 1233412" & @CRLF & _
"12334 12323 12334 122 33" & @CRLF & _
"12334 12323 12334 12323 123 34" & @CRLF & _
"asd 123132" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Результат:" & @CRLF & _
"12334 12323 12334 123" & @CRLF & _
"12334 12323 12334 1" & @CRLF & _
"12334 12323 12334 12323 12334" & @CRLF & _
"12334 12323 12334 12323 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")