const regex = /^\d{5}\s\d{5}\s\d{5}\s\d{1,5}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{5}\\s\\d{5}\\s\\d{5}\\s\\d{1,5}', 'gm')
const str = `Дано:
12334 12323 12334 12323 12334 12312313231231
12334 12323 12334 12323 12334 12312313231231
123 123
12334 12323 12334
12334 12323 12334
12334 12323 1233412
12334 12323 12334 122 33
12334 12323 12334 12323 123 34
asd 123132
Результат:
12334 12323 12334 123
12334 12323 12334 1
12334 12323 12334 12323 12334
12334 12323 12334 12323 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}