use strict;
my $str = 'Дано:
12334 12323 12334 12323 12334 12312313231231
12334 12323 12334 12323 12334 12312313231231
123 123
12334 12323 12334
12334 12323 12334
12334 12323 1233412
12334 12323 12334 122 33
12334 12323 12334 12323 123 34
asd 123132
Результат:
12334 12323 12334 123
12334 12323 12334 1
12334 12323 12334 12323 12334
12334 12323 12334 12323 ';
my $regex = qr/^\d{5}\s\d{5}\s\d{5}\s\d{1,5}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}