using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{5}\s\d{5}\s\d{5}\s\d{1,5}";
string input = @"Дано:
12334 12323 12334 12323 12334 12312313231231
12334 12323 12334 12323 12334 12312313231231
123 123
12334 12323 12334
12334 12323 12334
12334 12323 1233412
12334 12323 12334 122 33
12334 12323 12334 12323 123 34
asd 123132
Результат:
12334 12323 12334 123
12334 12323 12334 1
12334 12323 12334 12323 12334
12334 12323 12334 12323 ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}