import Foundation
let pattern = #"^\d{5}\s\d{5}\s\d{5}\s\d{1,5}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Дано:
12334 12323 12334 12323 12334 12312313231231
12334 12323 12334 12323 12334 12312313231231
123 123
12334 12323 12334
12334 12323 12334
12334 12323 1233412
12334 12323 12334 122 33
12334 12323 12334 12323 123 34
asd 123132
Результат:
12334 12323 12334 123
12334 12323 12334 1
12334 12323 12334 12323 12334
12334 12323 12334 12323
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)