re = /^\d{5}\s\d{5}\s\d{5}\s\d{1,5}/m
str = 'Дано:
12334 12323 12334 12323 12334 12312313231231
12334 12323 12334 12323 12334 12312313231231
123 123
12334 12323 12334
12334 12323 12334
12334 12323 1233412
12334 12323 12334 122 33
12334 12323 12334 12323 123 34
asd 123132
Результат:
12334 12323 12334 123
12334 12323 12334 1
12334 12323 12334 12323 12334
12334 12323 12334 12323 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end