import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{5}\\s\\d{5}\\s\\d{5}\\s\\d{1,5}";
final String string = "Дано:\n"
+ " 12334 12323 12334 12323 12334 12312313231231\n"
+ "12334 12323 12334 12323 12334 12312313231231\n"
+ "123 123\n"
+ "12334 12323 12334 \n"
+ "12334 12323 12334 \n"
+ "12334 12323 1233412\n"
+ "12334 12323 12334 122 33\n"
+ "12334 12323 12334 12323 123 34\n"
+ "asd 123132\n\n\n"
+ "Результат:\n"
+ "12334 12323 12334 123\n"
+ "12334 12323 12334 1\n"
+ "12334 12323 12334 12323 12334\n"
+ "12334 12323 12334 12323 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}