using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:Version:\s)(0|[1-9]\d*)\.?(0|[1-9]\d*)?\.?(0|[1-9]\d*)?(?:-((?:0|[1-9]\d*|\d*[a-zA-Z][0-9a-zA-Z]*)(?:\.(?:0|[1-9]\d*|\d*[a-zA-Z][0-9a-zA-Z]*))*))?(.+)?$";
string input = @"Version: 2
Version: 2.2.0-alpha-dev
Version: 2.2-alpha-dev
Version: 2-alpha-dev
Version: 2.2.0-alpha
Version: 2.2-alpha
Version: 2.2.0-alpha
Version: 2.2.0-alpha+123123
Version: 2.2.0-alpha
Version: 2.2-alpha
Version: 2-alpha
Version: 2.2.0-alpha
Version: 2.2-alpha
Version: 2.2.0-alpha
Version: 2.2.0-alpha
Version: 2.2.0-
Version: 2.2-
Version: 2-
Version: 2.2.0-
Version: 2.2-
Version: 2.2.0-
Version: 2.2.0-
Version: 2.2.0
Version: 2.2
Version: 2.
Version: 2.2.0
Version: 2.2
Version: 2.2.0
Version: 2.2.0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}