const regex = /^(?:Version:\s)(0|[1-9]\d*)\.?(0|[1-9]\d*)?\.?(0|[1-9]\d*)?(?:-((?:0|[1-9]\d*|\d*[a-zA-Z][0-9a-zA-Z]*)(?:\.(?:0|[1-9]\d*|\d*[a-zA-Z][0-9a-zA-Z]*))*))?(.+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:Version:\\s)(0|[1-9]\\d*)\\.?(0|[1-9]\\d*)?\\.?(0|[1-9]\\d*)?(?:-((?:0|[1-9]\\d*|\\d*[a-zA-Z][0-9a-zA-Z]*)(?:\\.(?:0|[1-9]\\d*|\\d*[a-zA-Z][0-9a-zA-Z]*))*))?(.+)?$', 'gm')
const str = `Version: 2
Version: 2.2.0-alpha-dev
Version: 2.2-alpha-dev
Version: 2-alpha-dev
Version: 2.2.0-alpha
Version: 2.2-alpha
Version: 2.2.0-alpha
Version: 2.2.0-alpha+123123
Version: 2.2.0-alpha
Version: 2.2-alpha
Version: 2-alpha
Version: 2.2.0-alpha
Version: 2.2-alpha
Version: 2.2.0-alpha
Version: 2.2.0-alpha
Version: 2.2.0-
Version: 2.2-
Version: 2-
Version: 2.2.0-
Version: 2.2-
Version: 2.2.0-
Version: 2.2.0-
Version: 2.2.0
Version: 2.2
Version: 2.
Version: 2.2.0
Version: 2.2
Version: 2.2.0
Version: 2.2.0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}