import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:Version:\\s)(0|[1-9]\\d*)\\.?(0|[1-9]\\d*)?\\.?(0|[1-9]\\d*)?(?:-((?:0|[1-9]\\d*|\\d*[a-zA-Z][0-9a-zA-Z]*)(?:\\.(?:0|[1-9]\\d*|\\d*[a-zA-Z][0-9a-zA-Z]*))*))?(.+)?$";
final String string = "Version: 2\n"
+ "Version: 2.2.0-alpha-dev\n"
+ "Version: 2.2-alpha-dev\n"
+ "Version: 2-alpha-dev\n"
+ "Version: 2.2.0-alpha\n"
+ "Version: 2.2-alpha\n"
+ "Version: 2.2.0-alpha\n"
+ "Version: 2.2.0-alpha+123123\n"
+ "Version: 2.2.0-alpha\n"
+ "Version: 2.2-alpha\n"
+ "Version: 2-alpha\n"
+ "Version: 2.2.0-alpha\n"
+ "Version: 2.2-alpha\n"
+ "Version: 2.2.0-alpha\n"
+ "Version: 2.2.0-alpha\n"
+ "Version: 2.2.0-\n"
+ "Version: 2.2-\n"
+ "Version: 2-\n"
+ "Version: 2.2.0-\n"
+ "Version: 2.2-\n"
+ "Version: 2.2.0-\n"
+ "Version: 2.2.0-\n"
+ "Version: 2.2.0\n"
+ "Version: 2.2\n"
+ "Version: 2.\n"
+ "Version: 2.2.0\n"
+ "Version: 2.2\n"
+ "Version: 2.2.0\n"
+ "Version: 2.2.0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}