package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:Version:\s)(0|[1-9]\d*)\.?(0|[1-9]\d*)?\.?(0|[1-9]\d*)?(?:-((?:0|[1-9]\d*|\d*[a-zA-Z][0-9a-zA-Z]*)(?:\.(?:0|[1-9]\d*|\d*[a-zA-Z][0-9a-zA-Z]*))*))?(.+)?$`)
var str = `Version: 2
Version: 2.2.0-alpha-dev
Version: 2.2-alpha-dev
Version: 2-alpha-dev
Version: 2.2.0-alpha
Version: 2.2-alpha
Version: 2.2.0-alpha
Version: 2.2.0-alpha+123123
Version: 2.2.0-alpha
Version: 2.2-alpha
Version: 2-alpha
Version: 2.2.0-alpha
Version: 2.2-alpha
Version: 2.2.0-alpha
Version: 2.2.0-alpha
Version: 2.2.0-
Version: 2.2-
Version: 2-
Version: 2.2.0-
Version: 2.2-
Version: 2.2.0-
Version: 2.2.0-
Version: 2.2.0
Version: 2.2
Version: 2.
Version: 2.2.0
Version: 2.2
Version: 2.2.0
Version: 2.2.0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}