// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:Version:\s)(0|[1-9]\d*)\.?(0|[1-9]\d*)?\.?(0|[1-9]\d*)?(?:-((?:0|[1-9]\d*|\d*[a-zA-Z][0-9a-zA-Z]*)(?:\.(?:0|[1-9]\d*|\d*[a-zA-Z][0-9a-zA-Z]*))*))?(.+)?$").unwrap();
let string = "Version: 2
Version: 2.2.0-alpha-dev
Version: 2.2-alpha-dev
Version: 2-alpha-dev
Version: 2.2.0-alpha
Version: 2.2-alpha
Version: 2.2.0-alpha
Version: 2.2.0-alpha+123123
Version: 2.2.0-alpha
Version: 2.2-alpha
Version: 2-alpha
Version: 2.2.0-alpha
Version: 2.2-alpha
Version: 2.2.0-alpha
Version: 2.2.0-alpha
Version: 2.2.0-
Version: 2.2-
Version: 2-
Version: 2.2.0-
Version: 2.2-
Version: 2.2.0-
Version: 2.2.0-
Version: 2.2.0
Version: 2.2
Version: 2.
Version: 2.2.0
Version: 2.2
Version: 2.2.0
Version: 2.2.0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}