# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:Version:\s)(0|[1-9]\d*)\.?(0|[1-9]\d*)?\.?(0|[1-9]\d*)?(?:-((?:0|[1-9]\d*|\d*[a-zA-Z][0-9a-zA-Z]*)(?:\.(?:0|[1-9]\d*|\d*[a-zA-Z][0-9a-zA-Z]*))*))?(.+)?$"
test_str = ("Version: 2\n"
"Version: 2.2.0-alpha-dev\n"
"Version: 2.2-alpha-dev\n"
"Version: 2-alpha-dev\n"
"Version: 2.2.0-alpha\n"
"Version: 2.2-alpha\n"
"Version: 2.2.0-alpha\n"
"Version: 2.2.0-alpha+123123\n"
"Version: 2.2.0-alpha\n"
"Version: 2.2-alpha\n"
"Version: 2-alpha\n"
"Version: 2.2.0-alpha\n"
"Version: 2.2-alpha\n"
"Version: 2.2.0-alpha\n"
"Version: 2.2.0-alpha\n"
"Version: 2.2.0-\n"
"Version: 2.2-\n"
"Version: 2-\n"
"Version: 2.2.0-\n"
"Version: 2.2-\n"
"Version: 2.2.0-\n"
"Version: 2.2.0-\n"
"Version: 2.2.0\n"
"Version: 2.2\n"
"Version: 2.\n"
"Version: 2.2.0\n"
"Version: 2.2\n"
"Version: 2.2.0\n"
"Version: 2.2.0")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.