$re = '/^(?:Version:\s)(0|[1-9]\d*)\.?(0|[1-9]\d*)?\.?(0|[1-9]\d*)?(?:-((?:0|[1-9]\d*|\d*[a-zA-Z][0-9a-zA-Z]*)(?:\.(?:0|[1-9]\d*|\d*[a-zA-Z][0-9a-zA-Z]*))*))?(.+)?$/m';
$str = 'Version: 2
Version: 2.2.0-alpha-dev
Version: 2.2-alpha-dev
Version: 2-alpha-dev
Version: 2.2.0-alpha
Version: 2.2-alpha
Version: 2.2.0-alpha
Version: 2.2.0-alpha+123123
Version: 2.2.0-alpha
Version: 2.2-alpha
Version: 2-alpha
Version: 2.2.0-alpha
Version: 2.2-alpha
Version: 2.2.0-alpha
Version: 2.2.0-alpha
Version: 2.2.0-
Version: 2.2-
Version: 2-
Version: 2.2.0-
Version: 2.2-
Version: 2.2.0-
Version: 2.2.0-
Version: 2.2.0
Version: 2.2
Version: 2.
Version: 2.2.0
Version: 2.2
Version: 2.2.0
Version: 2.2.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);